Change has been implemented succesfully and testing of all impacted components have been done.
Important info: Users need to press restart when SPEAK softphone requires update when they open SPEAK.
Summarize of the change with bugfixes and new features: -------------------------------------------------------------------------------- Asterisk * reworked mediabank * changed how BLFs work in relation to the BLFs added to SPEAK app * call pickup fix for SPEAK clients * fixed ringplan behavior when SPEAK phones are used in a call fork * fixed ringing audio issue for simple queues
Core * implemented node branding select by node for SPEAK app * improved memory reporting * fixed license reporting issue * cleaned up excessive logging * added "show external catalog" to SPEAK app API * added external number status reset * subscription for BLFs to Asterisk now includes SPEAK phones * added BLF API implementation for SPEAK * added new translations
GUI * fixed a bug in mypage with voicemail buttons * fixed queue member bug with identical names * created bot prevention for exploiting phone provisioning * branding is now in node level instead of system level * fixed source private field being defaulted to "true" * Mitel software updated to 5.1.0.6044 * fixed various issues with access rights * leave number" in IVR now supports multiple emails/phones using ";" as a separator * new IVR misconfiguration added, when a switch is missing on or off path * fixed password strength checking when changing password from mypage * fixed password strength checking when changing password from password reset link * added outgoing wallboard type with reports for it * PAI parameter fixed for Mitel * default FlowApp menu items now created on node creation * added ring splash for Mitel * added collapsed more sofkey screen parameter for Mitels * added discreet ringing option for Mitel and Mitel sidepanels * added new side panel in provisioning templates (SPEAK side panel). SPEAK phones can now have side panels. * added + sign setting in trunks. * added Subscribe switch to Mitel BLFs. Provisioning will take notice of it and will send speeddial or blf. Added limit of 50 BLFs per phone on Mitel, user will not be able to save more than that. * set mitel re-sync delay to 30 minutes instead of 0. This will spread Mitel provisioning requests to avoid OOM errors. Fixed ternary operator in maskedfields inde file. * enabled provisioning rules cache, that cache now uses Redis instead of file system, changed how that cache is updated on certain GUI actions (its now updated instead of deleted), added ! symbols on some if the Mitel configuration lines (softlocks the params). * DS option in provisioning is now not counted towards BLF buttons sum * Mitel driver changes. intercom enabled, blf activity page switch disabled
SPEAK * added new page in settings called "Contacts". Catalog type can be seen and changed in there. Changing catalog type will immediately update catalog with new type. Added catalogType param to contacts GQL requests, added an icon after external contact name to identify it. * added more information on "Contact us" page, added users internal number and username in the header of the main application window. Added device name to queue login page to better identify queue membership. * if external user has a status, badge color will change, but text will stay the same. * when user closes app or logs out from it, it might get a popup asking if it wants to log out from queues that are related to this SPEAK client. Added checks to see if popup needs to be showed, also added queue switches update every 45 seconds to have latest queue switches data. * fixed tel protocol handling so users would be able to click on numbers and get them to SPEAK main window. * added internal number to contact view window * when app is closed, it will go to system tray instead of being shut down. It can be shut down from system tray. Application is able to receive calls when is minimized to system tray. * audio settings will popup on user login or app refresh if at least one audio device is not selected. This will inform the user that audio devices must be set. * added missed calls notification on top of "History" icon to display unseen missed calls. This clears after checking history and leaving it. * all logs in prod are now also written to file. * navigation buttons now navigate back to main window if pressed when active. Settings window is closed if it was opened when pressing setting button. * added a magic header on register for bot attack prevention * added a button on incoming call popup and main app window when incoming call is present to mute incoming call audio. * added a feature to switch language by pressing language button. These buttons are in login page and in settings "About" page. Clicking the button calls translations method which updates translations without restarting the application. * added logout option to system tray menu * added force reload and a feature to see and change user status in system tray. * added queue BLF updates from pushed status * integrated switches, modus switches, speed dial, call forward BLF with Java. * if user has just started outgoing call, new incoming queue call will be put to background and then cancelled after initial invite was sent for outgoing call. * added right click to copy on HistoryItem number box (copies the number) * added popups when hovered on names in ActiveCall window and IncomingCallPopup window. They can also be double clicked to copy the name to clipboard * moved auto answer together with call incoming request sending in same timeout window. This caused call to be auto picked up and then after timeout, the same call would start ringing. * BLF window will now be opened together with the main window from tray bar and minimized state. Also it will show BLF window on top if it lost focus when focusing main window. * added extra check on SPEAK startup to see if settings window was destroyed. If not destroyed, then it is destroyed. This caused errors on reload.
WebRTC-Gateway * Exploit for bot attacks fixed. Now resistant to all known attacks --------------------------------------------------------------------------------
Posted Jun 27, 2021 - 12:01 CEST
Completed
The scheduled maintenance has been completed.
Posted Jun 27, 2021 - 12:00 CEST
Verifying
Upgrade is done. We are in the process of verifying services.
Posted Jun 27, 2021 - 11:44 CEST
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jun 27, 2021 - 09:00 CEST
Scheduled
Change - C30029875 - Normal Change:
We will upgrade central components in the cluster hosting portal.smartvoice.no this sunday. Componens that are affected are: * Asterisk * Core * Web-GUI * UCP-GUI * Speak softphone * Web-RTC gateway
The platform will experience some short periodes of downtime. The total upgrade are estimated to take aprox one hour. The change window is from 9 am to 12 am including testing.
When SPEAK are upgraded, users should be informed in SPEAK that a new version is availiable. Then users can upgrade by pushing the "Restart now" button.
Posted Jun 22, 2021 - 09:33 CEST
This scheduled maintenance affected: Core Services (SIP Gateway, Smartvoice Backend, WebRTC Proxy), Applications (Speak (Softphone)), and Web (Portal, Switchboard).